summary refs log tree commit diff
path: root/gnu/packages/perl-maths.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/perl-maths.scm')
-rw-r--r--gnu/packages/perl-maths.scm10
1 files changed, 7 insertions, 3 deletions
diff --git a/gnu/packages/perl-maths.scm b/gnu/packages/perl-maths.scm
index 4f70c85fcf..b317e3c1cf 100644
--- a/gnu/packages/perl-maths.scm
+++ b/gnu/packages/perl-maths.scm
@@ -35,7 +35,12 @@
                     version ".tar.gz"))
               (sha256
                (base32
-                "18c3xg53d1vv7hlj43601jj7ks119fm6ndpwpv94irr2905806jn"))))
+                "18c3xg53d1vv7hlj43601jj7ks119fm6ndpwpv94irr2905806jn"))
+              ;; For reproducibility
+              (modules '((guix build utils)))
+              (snippet
+               '(substitute* "libmd/Makefile.PL"
+                  (("readdir DIR") "sort readdir DIR")))))
     (build-system perl-build-system)
     (home-page "https://metacpan.org/release/Math-Cephes")
     (synopsis "Perl interface to the Cephes math library")
@@ -57,8 +62,7 @@
                 "1cml5wqd99hm398gl8f147ccsck9v179l7a6vqjj4kfkdnja37sg"))))
     (build-system perl-build-system)
     (native-inputs
-     `(("perl-module-build" ,perl-module-build)
-       ("perl-test-most" ,perl-test-most)))
+     (list perl-module-build perl-test-most))
     (home-page "https://metacpan.org/release/Math-MatrixReal")
     (synopsis "Manipulate NxN matrices of real numbers")
     (description "This package provides the @code{Math::MatrixReal} module.