summary refs log tree commit diff
path: root/gnu/packages/perl.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/perl.scm')
-rw-r--r--gnu/packages/perl.scm18
1 files changed, 18 insertions, 0 deletions
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index b3b6061c7c..19a7550917 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -1719,6 +1719,24 @@ Devel::StackTrace::WithLexicals, you even get to see the lexical variables of
 each stack frame.")
     (license (package-license perl))))
 
+(define-public perl-devel-symdump
+  (package
+    (name "perl-devel-symdump")
+    (version "2.14")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "mirror://cpan/authors/id/A/AN/ANDK/"
+                           "Devel-Symdump-" version ".tar.gz"))
+       (sha256
+        (base32
+         "1phyyxgxsymgzbjd524zlaavvay6vjw34af5zn9153qffqign54v"))))
+    (build-system perl-build-system)
+    (home-page "http://search.cpan.org/dist/Devel-Symdump")
+    (synopsis "Dump symbol names or the symbol table")
+    (description "Devel::Symdump provides access to the perl symbol table.")
+    (license (package-license perl))))
+
 (define-public perl-digest-hmac
   (package
     (name "perl-digest-hmac")