summary refs log tree commit diff
path: root/gnu/packages/perl.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/perl.scm')
-rw-r--r--gnu/packages/perl.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index 4bc7a2ace0..0b3666107e 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -3433,6 +3433,29 @@ you want to do full file globbing use the File::Glob module instead.")
     (description "Text::SimpleTable draws simple ASCII tables.")
     (license artistic2.0)))
 
+(define-public perl-text-unidecode
+  (package
+    (name "perl-text-unidecode")
+    (version "1.23")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "mirror://cpan/authors/id/S/SB/SBURKE/"
+                           "Text-Unidecode-" version ".tar.gz"))
+       (sha256
+        (base32
+         "1mnnq57amh0bs6z2ggkmgnn4hz8mqc9lfhr66xv2bsnlvhg7c7fb"))))
+    (build-system perl-build-system)
+    (home-page "http://search.cpan.org/dist/Text-Unidecode")
+    (synopsis "Provide plain ASCII transliterations of Unicode text")
+    (description "Text::Unidecode provides a function, unidecode(...) that
+takes Unicode data and tries to represent it in US-ASCII characters (i.e., the
+universally displayable characters between 0x00 and 0x7F).  The representation
+is almost always an attempt at transliteration-- i.e., conveying, in Roman
+letters, the pronunciation expressed by the text in some other writing
+system.")
+    (license (package-license perl))))
+
 (define-public perl-time-local
   (package
     (name "perl-time-local")