summary refs log tree commit diff
path: root/gnu/packages/pumpio.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/pumpio.scm')
-rw-r--r--gnu/packages/pumpio.scm33
1 files changed, 17 insertions, 16 deletions
diff --git a/gnu/packages/pumpio.scm b/gnu/packages/pumpio.scm
index a74d474368..e89418b6b1 100644
--- a/gnu/packages/pumpio.scm
+++ b/gnu/packages/pumpio.scm
@@ -42,22 +42,23 @@
               (file-name (string-append name "-" version "-checkout"))))
     (build-system gnu-build-system)
     (arguments
-     '(#:phases (alist-replace
-                 'configure
-                 (lambda* (#:key inputs outputs #:allow-other-keys)
-                   ;; Fix dependency tests.
-                   (substitute* "pumpa.pro"
-                     (("/usr/include/tidy\\.h")
-                      (string-append (assoc-ref inputs "tidy")
-                                     "/include/tidy.h"))
-                     (("/usr/include/aspell.h")
-                      (string-append (assoc-ref inputs "aspell")
-                                     "/include/aspell.h")))
-                   ;; Run qmake with proper installation prefix.
-                   (let ((prefix (string-append "PREFIX="
-                                                (assoc-ref outputs "out"))))
-                     (zero? (system* "qmake" prefix))))
-                 %standard-phases)))
+     '(#:phases
+       (modify-phases %standard-phases
+         (replace 'configure
+           (lambda* (#:key inputs outputs #:allow-other-keys)
+             ;; Fix dependency tests.
+             (substitute* "pumpa.pro"
+               (("/usr/include/tidy\\.h")
+                (string-append (assoc-ref inputs "tidy")
+                               "/include/tidy.h"))
+               (("/usr/include/aspell.h")
+                (string-append (assoc-ref inputs "aspell")
+                               "/include/aspell.h")))
+             ;; Run qmake with proper installation prefix.
+             (let ((prefix (string-append "PREFIX="
+                                          (assoc-ref outputs "out"))))
+               (zero? (system* "qmake" prefix)))
+             #t)))))
     (inputs
      `(("aspell" ,aspell)
        ("qtbase" ,qtbase)