summary refs log tree commit diff
path: root/gnu/packages/python-check.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/python-check.scm')
-rw-r--r--gnu/packages/python-check.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/python-check.scm b/gnu/packages/python-check.scm
index 1e59911299..fa382f6f35 100644
--- a/gnu/packages/python-check.scm
+++ b/gnu/packages/python-check.scm
@@ -127,6 +127,26 @@ written in pure Python.")
 interfaces with pytest.")
     (license license:expat)))
 
+(define-public python-pytest-cram
+  (package
+    (name "python-pytest-cram")
+    (version "0.2.2")
+    (source (origin
+              (method url-fetch)
+              (uri (pypi-uri "pytest-cram" version))
+              (sha256
+               (base32
+                "0405ymmrsv6ii2qhq35nxfjkb402sdb6d13xnk53jql3ybgmiqq0"))))
+    (build-system python-build-system)
+    (propagated-inputs (list python-cram python-pytest))
+    (home-page "https://github.com/tbekolay/pytest-cram")
+    (synopsis "Run cram tests with pytest.")
+    (description "Cram tests command line applications; Pytest tests Python
+applications.  @code{pytest-cram} tests Python command line applications by
+letting you write your Python API tests with pytest, and your command line
+tests in cram.")
+    (license license:expat)))
+
 (define-public python-pytest-csv
   (package
     (name "python-pytest-csv")