summary refs log tree commit diff
path: root/gnu/packages/python-web.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/python-web.scm')
-rw-r--r--gnu/packages/python-web.scm12
1 files changed, 1 insertions, 11 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index f4302e0108..398f2891dd 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -2723,17 +2723,7 @@ APIs.")
     (description
      "Requests is a Python HTTP client library.  It aims to be easier to use
 than Python’s urllib2 library.")
-    (license license:asl2.0)
-    (properties `((python2-variant . ,(delay python2-requests))))))
-
-(define-public python2-requests
-  (let ((base (package-with-python2 (strip-python2-variant python-requests))))
-    (package
-      (inherit base)
-      ;; The python-charset-normalizer dependency is necessary on Python 3
-      ;; only.
-      (propagated-inputs (modify-inputs (package-propagated-inputs base)
-                           (delete "python-charset-normalizer"))))))
+    (license license:asl2.0)))
 
 (define-public python-requests-unixsocket
   (package