summary refs log tree commit diff
path: root/gnu/packages/python.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/python.scm')
-rw-r--r--gnu/packages/python.scm58
1 files changed, 26 insertions, 32 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index db8bf5d576..ad475d8acc 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -30,7 +30,7 @@
 ;;; Copyright © 2016, 2017 Stefan Reichör <stefan@xsteve.at>
 ;;; Copyright © 2016, 2017 Alex Vong <alexvong1995@gmail.com>
 ;;; Copyright © 2016, 2017, 2018 Arun Isaac <arunisaac@systemreboot.net>
-;;; Copyright © 2016–2018, 2021 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2016–2018, 2021, 2022 Tobias Geerinckx-Rice <me@tobias.gr>
 ;;; Copyright © 2016, 2017, 2018, 2021 Julien Lepiller <julien@lepiller.eu>
 ;;; Copyright © 2016, 2017 Thomas Danckaert <post@thomasdanckaert.be>
 ;;; Copyright © 2017 Carlo Zancanaro <carlo@zancanaro.id.au>
@@ -673,7 +673,7 @@ To function properly, this package should not be installed together with the
 (define-public micropython
   (package
     (name "micropython")
-    (version "1.15")
+    (version "1.18")
     (source
       (origin
         (method url-fetch)
@@ -681,7 +681,7 @@ To function properly, this package should not be installed together with the
                             "releases/download/v" version
                             "/micropython-" version ".tar.xz"))
         (sha256
-         (base32 "04sfrfcljhfps340l4wh5ffwkhw1ydraday8nv92nv7gmnrj1l2j"))
+         (base32 "1d1yza02pwq3kh8531ryq9sjk7zjqh786nnw397cccfk5ss73z4n"))
       (modules '((guix build utils)))
       (snippet
        '(begin
@@ -689,37 +689,31 @@ To function properly, this package should not be installed together with the
           (with-directory-excursion "lib"
             ;; TODO: Unbundle axtls and berkley-db-1.xx
             (for-each delete-file-recursively
-                      '("libffi" "lwip" "stm32lib" "nrfx")))
-          #t))))
+                      '("libffi" "lwip" "stm32lib" "nrfx")))))))
     (build-system gnu-build-system)
     (arguments
-     `(#:phases
-       (modify-phases %standard-phases
-         (add-before 'build 'build-mpy-cross
-           (lambda* (#:key make-flags #:allow-other-keys)
-             (with-directory-excursion "mpy-cross"
-               (apply invoke "make" make-flags))))
-         (add-after 'build-mpy-cross 'prepare-build
-           (lambda _
-             (chdir "ports/unix")
-             ;; see: https://github.com/micropython/micropython/pull/4246
-             (substitute* "Makefile"
-               (("-Os") "-Os -ffp-contract=off"))
-             #t))
-         (replace 'install-license-files
-           ;; We don't build in the root directory so the file isn't found.
-           (lambda* (#:key outputs #:allow-other-keys)
-             (let* ((out  (assoc-ref outputs "out"))
-                    (dest (string-append out "/share/doc/" ,name "-" ,version "/")))
-               (install-file "../../LICENSE" dest))
-             #t))
-         (delete 'configure)) ; no configure
-       #:make-flags (list (string-append "PREFIX=" (assoc-ref %outputs "out"))
-                          "V=1")
-       #:test-target "test"))
-    (native-inputs
-     `(("pkg-config" ,pkg-config)
-       ("python" ,python-wrapper)))
+     (list #:phases
+           #~(modify-phases %standard-phases
+               (add-before 'build 'build-mpy-cross
+                 (lambda* (#:key make-flags #:allow-other-keys)
+                   (with-directory-excursion "mpy-cross"
+                     (apply invoke "make" make-flags))))
+               (add-after 'build-mpy-cross 'prepare-build
+                 (lambda _
+                   (chdir "ports/unix")
+                   ;; see: https://github.com/micropython/micropython/pull/4246
+                   (substitute* "Makefile"
+                     (("-Os") "-Os -ffp-contract=off"))))
+               (add-before 'install-license-files 'chdir-back
+                 ;; We don't build in the root directory so the file isn't found.
+                 (lambda _
+                   (chdir "../..")))
+               (delete 'configure))       ; no configure
+           #:make-flags
+           #~(list (string-append "PREFIX=" #$output)
+                   "V=1")
+           #:test-target "test"))
+    (native-inputs (list pkg-config python-wrapper))
     (inputs
      (list libffi))
     (home-page "https://micropython.org/")