summary refs log tree commit diff
path: root/gnu/packages/python.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/python.scm')
-rw-r--r--gnu/packages/python.scm37
1 files changed, 32 insertions, 5 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 30b0bdd22f..26a9113297 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -3744,6 +3744,34 @@ routines such as routines for numerical integration and optimization.")
 (define-public python2-scipy
   (package-with-python2 python-scipy))
 
+(define-public python-socksipy-branch
+  (package
+    (name "python-socksipy-branch")
+    (version "1.01")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "SocksiPy-branch" version))
+       (sha256
+        (base32
+         "01l41v4g7fy9fzvinmjxy6zcbhgqaif8dhdqm4w90fwcw9h51a8p"))))
+    (build-system python-build-system)
+    (arguments
+     `(#:tests? #f)) ; There are no tests
+    (home-page "https://code.google.com/archive/p/socksipy-branch/")
+    (synopsis "Python SOCKS module")
+    (description
+     "SocksiPy - A Python SOCKS client module.  It provides a
+socket-like interface that supports connections to any TCP
+service through the use of a SOCKS4, SOCKS5 or HTTP proxy.
+The original version was developed by Dan Haim, this is a
+branch created by Mario Vilas to address some open issues,
+as the original project seems to have been abandoned circa 2007.")
+    (license license:bsd-3)))
+
+(define-public python2-socksipy-branch
+  (package-with-python2 python-socksipy-branch))
+
 (define-public python-sqlalchemy
   (package
     (name "python-sqlalchemy")
@@ -5876,19 +5904,18 @@ object to help create WSGI responses.")
 (define-public python-xlrd
   (package
     (name "python-xlrd")
-    (version "0.9.4")
+    (version "1.0.0")
     (source (origin
               (method url-fetch)
-              (uri (string-append "https://pypi.python.org/packages/source/x/"
-                                  "xlrd/xlrd-" version ".tar.gz"))
+              (uri (pypi-uri "xlrd" version))
               (sha256
                (base32
-                "0wpa55nvidmm5m2qr622dsh3cj46akdk0h3zjgzschcmydck73cf"))))
+                "0s8hjiz01vbhy85xalrz0qlsmd9ypf36zjqrf97hh984spapvy0g"))))
     (build-system python-build-system)
     (arguments
      `(#:phases
        (modify-phases %standard-phases
-         ;; Current test in setup.py does not work as of 0.9.4, so use nose to
+         ;; Current test in setup.py does not work as of 1.0.0, so use nose to
          ;; run tests instead for now.
          (replace 'check (lambda _ (zero? (system* "nosetests")))))))
     (native-inputs `(("python-nose"       ,python-nose)