summary refs log tree commit diff
path: root/gnu/packages/python.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/python.scm')
-rw-r--r--gnu/packages/python.scm28
1 files changed, 5 insertions, 23 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 23d18909a3..800b08c373 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -66,34 +66,16 @@
 
         #:modules ((guix build gnu-build-system)
                    (guix build utils)
-                   (ice-9 popen)
-                   (ice-9 rdelim)
+                   (guix build rpath)
                    (srfi srfi-26))
+        #:imported-modules ((guix build gnu-build-system)
+                            (guix build utils)
+                            (guix build rpath))
 
         #:phases
         (alist-cons-after
          'strip 'add-lib-to-runpath
          (lambda* (#:key outputs #:allow-other-keys)
-           ;; XXX: copied from Samba; TODO: factorize in a module
-
-           (define (file-rpath file)
-             ;; Return the RPATH of FILE.
-             (let* ((p (open-pipe* OPEN_READ "patchelf"
-                                   "--print-rpath" file))
-                    (l (read-line p)))
-               (and (zero? (close-pipe p)) l)))
-
-           (define (augment-rpath file dir)
-             ;; Add DIR to the RPATH of FILE.
-             (let* ((rpath  (file-rpath file))
-                    (rpath* (if rpath
-                                (string-append dir ":" rpath)
-                                dir)))
-               (format #t "~a: changing RPATH from `~a' to `~a'~%"
-                       file (or rpath "") rpath*)
-               (zero? (system* "patchelf" "--set-rpath"
-                               rpath* file))))
-
            (let* ((out (assoc-ref outputs "out"))
                   (lib (string-append out "/lib")))
              ;; Add LIB to the RUNPATH of all the executables.
@@ -107,7 +89,7 @@
        ("openssl" ,openssl)
        ("readline" ,readline)
        ("zlib" ,zlib)
-       ("patchelf" ,patchelf)))
+       ("patchelf" ,patchelf)))                   ; for (guix build rpath)
     (native-search-paths
      (list (search-path-specification
             (variable "PYTHONPATH")