summary refs log tree commit diff
path: root/gnu/packages/python.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/python.scm')
-rw-r--r--gnu/packages/python.scm24
1 files changed, 21 insertions, 3 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 3db29e23f1..730faf4557 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -2826,14 +2826,14 @@ and is very extensible.")
 (define-public python-cython
   (package
     (name "python-cython")
-    (version "0.27")
+    (version "0.28.4")
     (source
      (origin
        (method url-fetch)
        (uri (pypi-uri "Cython" version))
        (sha256
         (base32
-         "02y0pp1nx77b8s1mpxc6da2dccl6wd31pp4ksi9via479qcvacmr"))))
+         "0imw9s2rbrh32clbl10csnwmig9p3nzkrd2baxxxfmnrsc42pb3n"))))
     (build-system python-build-system)
     ;; we need the full python package and not just the python-wrapper
     ;; because we need libpython3.3m.so
@@ -2845,8 +2845,26 @@ and is very extensible.")
          (add-before 'check 'set-HOME
            ;; some tests require access to "$HOME/.cython"
            (lambda _ (setenv "HOME" "/tmp") #t))
+
+         ;; FIXME: These tests started failing on armhf after the 0.28 update
+         ;; (commit c69d11c5930), both with an error such as this:
+         ;;  compiling (cpp) and running dictcomp ...
+         ;;  === C/C++ compiler error output: ===
+         ;;  ‘
+         ;;  dictcomp.cpp:5221: confused by earlier errors, bailing out
+         ;; See <https://hydra.gnu.org/build/2948724> for logs.
+         ,@(if (target-arm32?)
+               `((add-before 'check 'disable-failing-tests
+                  (lambda _
+                    (let ((disabled-tests (open-file "tests/bugs.txt" "a")))
+                      (for-each (lambda (test)
+                                  (format disabled-tests "~a\n" test))
+                                '("memslice" "dictcomp"))
+                      (close-port disabled-tests)))))
+               '())
+
          (replace 'check
-           (lambda _ (zero? (system* "python" "runtests.py" "-vv")))))))
+           (lambda _ (invoke "python" "runtests.py" "-vv"))))))
     (home-page "http://cython.org/")
     (synopsis "C extensions for Python")
     (description "Cython is an optimising static compiler for both the Python