summary refs log tree commit diff
path: root/gnu/packages/python.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/python.scm')
-rw-r--r--gnu/packages/python.scm3
1 files changed, 2 insertions, 1 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 65daba4e4b..fc72bb25e1 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -5660,7 +5660,8 @@ complexity of Python source code.")
          (add-after 'install 'check
           (lambda* (#:key inputs outputs #:allow-other-keys)
             (add-installed-pythonpath inputs outputs)
-            (zero? (system* "pytest" "-v")))))))
+            (invoke "pytest" "-v")
+            #t)))))
     (propagated-inputs
       `(("python-pycodestyle" ,python-pycodestyle)
         ("python-pyflakes" ,python-pyflakes)