summary refs log tree commit diff
path: root/gnu/packages/python.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/python.scm')
-rw-r--r--gnu/packages/python.scm19
1 files changed, 7 insertions, 12 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 01de2f6a4a..6b4d450599 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -139,18 +139,13 @@
              (with-directory-excursion out
                (for-each (cut augment-rpath <> lib)
                          (find-files "bin" ".*")))))
-         (alist-replace
-          'configure
-          (lambda* (#:key outputs #:allow-other-keys #:rest args)
-            (let ((configure (assoc-ref %standard-phases 'configure)))
-             (substitute* "Lib/subprocess.py"
-               (("args = \\[\"/bin/sh")
-                (string-append "args = [\"" (which "sh"))))
-             (substitute*
-               '("Lib/distutils/tests/test_spawn.py"
-                 "Lib/test/test_subprocess.py")
-               (("/bin/sh") (which "sh")))
-             (apply configure args)))
+         (alist-cons-before
+          'configure 'patch-lib-shells
+          (lambda _
+            (substitute* '("Lib/subprocess.py"
+                           "Lib/distutils/tests/test_spawn.py"
+                           "Lib/test/test_subprocess.py")
+              (("/bin/sh") (which "sh"))))
           (alist-cons-before
            'check 'pre-check
            (lambda _