summary refs log tree commit diff
path: root/gnu/packages/python.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/python.scm')
-rw-r--r--gnu/packages/python.scm6
1 files changed, 5 insertions, 1 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 106c040bf8..d091157d8a 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -357,7 +357,11 @@ data types.")
                   (for-each delete-file
                             '("Lib/ctypes/test/test_structures.py" ; fails on aarch64
                               "Lib/ctypes/test/test_win32.py" ; fails on aarch64
-                              "Lib/test/test_fcntl.py")) ; fails on aarch64
+                              "Lib/test/test_fcntl.py" ; fails on aarch64
+                              ;; This test fails on kernels older than 4.5.
+                              ;; It is skipped on these kernels in later
+                              ;; versions of Python.
+                              "Lib/test/test_socket.py"))
                   #t))))
     (arguments (substitute-keyword-arguments (package-arguments python-2)
                  ((#:tests? _) #t)))