summary refs log tree commit diff
path: root/gnu/packages/python.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/python.scm')
-rw-r--r--gnu/packages/python.scm24
1 files changed, 21 insertions, 3 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 630396c43f..e342d62a03 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -50,6 +50,7 @@
 ;;; Copyright © 2018 Vijayalakshmi Vedantham <vijimay12@gmail.com>
 ;;; Copyright © 2018 Mathieu Lirzin <mthl@gnu.org>
 ;;; Copyright © 2018 Adam Massmann <massmannak@gmail.com>
+;;; Copyright © 2016, 2018 Tomáš Čech <sleep_walker@gnu.org>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -102,7 +103,6 @@
   #:use-module (gnu packages networking)
   #:use-module (gnu packages ncurses)
   #:use-module (gnu packages openstack)
-  #:use-module (gnu packages password-utils)
   #:use-module (gnu packages pcre)
   #:use-module (gnu packages perl)
   #:use-module (gnu packages pkg-config)
@@ -6342,7 +6342,7 @@ specification.")
 (define-public python-pretend
   (package
     (name "python-pretend")
-    (version "1.0.8")
+    (version "1.0.9")
     (source
      (origin
        (method url-fetch)
@@ -6350,7 +6350,7 @@ specification.")
                            "pretend/pretend-" version ".tar.gz"))
        (sha256
         (base32
-         "0r5r7ygz9m6d2bklflbl84cqhjkc2q12xgis8268ygjh30g2q3wk"))))
+         "040vm94lcbscg5p81g1icmwwwa2jm7wrd1ybmxnv1sz8rl8bh3n9"))))
     (build-system python-build-system)
     (home-page "https://github.com/alex/pretend")
     (synopsis "Library for stubbing in Python")
@@ -13251,3 +13251,21 @@ working with iterables.")
     (description "Pybtex is a BibTeX-compatible bibliography processor written
 in Python.  You can simply type pybtex instead of bibtex.")
     (license license:expat)))
+
+(define-public python-onetimepass
+  (package
+    (name "python-onetimepass")
+    (version "1.0.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "onetimepass" version))
+       (sha256
+        (base32 "09vagxgbq78wvq4xbikmn2hpqqsa2i96kqsmphf7dqynfv0dlsd5"))))
+    (build-system python-build-system)
+    (inputs `(("python-six" ,python-six)))
+    (home-page "https://github.com/tadeck/onetimepass/")
+    (synopsis "One-time password library")
+    (description "Python one-time password library for HMAC-based (HOTP) and
+time-based (TOTP) passwords.")
+    (license license:expat)))