summary refs log tree commit diff
path: root/gnu/packages/python.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/python.scm')
-rw-r--r--gnu/packages/python.scm11
1 files changed, 2 insertions, 9 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 7e139322e5..1c5cda5cfb 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -149,7 +149,8 @@
                                 "python-2.7-site-prefixes.patch"
                                 "python-2.7-source-date-epoch.patch"
                                 "python-2.7-adjust-tests.patch"
-                                "python-cross-compile.patch"))
+                                "python-cross-compile.patch"
+                                "python-2.7-CVE-2021-3177.patch"))
        (modules '((guix build utils)))
        (snippet
         '(begin
@@ -378,14 +379,6 @@ data types.")
     (properties '((cpe-name . "python")))
     (license license:psfl)))
 
-(define python-2.7/fixed
-  (package
-    (inherit python-2.7)
-    (source (origin
-              (inherit (package-source python-2.7))
-              (patches (append (search-patches "python-2.7-CVE-2021-3177.patch")
-                               (origin-patches (package-source python-2.7))))))))
-
 ;; Current 2.x version.
 (define-public python-2 python-2.7)