summary refs log tree commit diff
path: root/gnu/packages/qemu.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/qemu.scm')
-rw-r--r--gnu/packages/qemu.scm10
1 files changed, 3 insertions, 7 deletions
diff --git a/gnu/packages/qemu.scm b/gnu/packages/qemu.scm
index 6979655122..b2ef95d03b 100644
--- a/gnu/packages/qemu.scm
+++ b/gnu/packages/qemu.scm
@@ -44,16 +44,15 @@
   ;; This is QEMU without GUI support.
   (package
     (name "qemu-headless")
-    (version "2.3.0")
+    (version "2.3.1")
     (source (origin
              (method url-fetch)
              (uri (string-append "http://wiki.qemu-project.org/download/qemu-"
                                  version ".tar.bz2"))
              (sha256
               (base32
-               "120m53c3p28qxmfzllicjzr8syjv6v4d9rsyrgkp7gnmcgvvgfmn"))
+               "0px1vhkglxzjdxkkqln98znv832n1sn79g5inh3aw72216c047b6"))
              (patches (map search-patch '("qemu-CVE-2015-3209.patch"
-                                          "qemu-CVE-2015-3456.patch"
                                           "qemu-CVE-2015-4037.patch"
                                           "qemu-CVE-2015-4103.patch"
                                           "qemu-CVE-2015-4104.patch"
@@ -66,10 +65,7 @@
                                           "qemu-CVE-2015-4106-pt6.patch"
                                           "qemu-CVE-2015-4106-pt7.patch"
                                           "qemu-CVE-2015-4106-pt8.patch"
-                                          "qemu-CVE-2015-5154-pt1.patch"
-                                          "qemu-CVE-2015-5154-pt2.patch"
-                                          "qemu-CVE-2015-5154-pt3.patch"
-                                          "qemu-CVE-2015-5158.patch")))))
+                                          "qemu-CVE-2015-5745.patch")))))
     (build-system gnu-build-system)
     (arguments
      '(#:phases (alist-replace