summary refs log tree commit diff
path: root/gnu/packages/racket.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/racket.scm')
-rw-r--r--gnu/packages/racket.scm24
1 files changed, 15 insertions, 9 deletions
diff --git a/gnu/packages/racket.scm b/gnu/packages/racket.scm
index 4bc34193c6..661443e0c3 100644
--- a/gnu/packages/racket.scm
+++ b/gnu/packages/racket.scm
@@ -1,5 +1,5 @@
 ;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2013, 2014, 2015, 2016, 2018, 2020 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2013, 2014, 2015, 2016, 2018, 2020, 2021 Ludovic Courtès <ludo@gnu.org>
 ;;; Copyright © 2017, 2018, 2019, 2020 Tobias Geerinckx-Rice <me@tobias.gr>
 ;;; Copyright © 2020 Pierre Neidhardt <mail@ambrevar.xyz>
 ;;; Copyright © 2021 Philip McGrath <philip@philipmcgrath.com>
@@ -138,18 +138,23 @@
        (sha256
         "061bhiyjlvazph0dj9i3i3x2q5z53rp8h5cjwg3frjimkr45lncn")
        (file-name (git-file-name name version))
-       (patches (search-patches "racket-minimal-sh-via-rktio.patch"))
+       (patches (search-patches "racket-minimal-sh-via-rktio.patch"
+                                ;; Remove the following in version 8.3:
+                                "racket-minimal-backport-1629887.patch"))
+       (modules '((guix build utils)))
        (snippet
         (with-imported-modules '((guix build utils))
           #~(begin
-              (use-modules (guix build utils))
-              ;; unbundle Chez submodules
+              ;; Unbundle Chez submodules.
               (with-directory-excursion "racket/src/ChezScheme"
-                #$(origin-snippet (package-source chez-scheme)))
-              ;; unbundle libffi
-              (for-each
-               delete-file-recursively
-               '("racket/src/bc/foreign/libffi")))))))
+                ;; Remove bundled libraries (copied from 'chez-scheme').
+                (for-each delete-file-recursively
+                          '("stex"
+                            "nanopass"
+                            "lz4"
+                            "zlib")))
+              ;; Unbundle libffi.
+              (delete-file-recursively "racket/src/bc/foreign/libffi"))))))
     (inputs
      `(;; common to all racket-minimal variants:
        ("openssl" ,openssl)
@@ -212,6 +217,7 @@
                                                    "/lib"))
                                   '("openssl"
                                     "sqlite"))))
+                    (build-stamp . "")
                     (catalogs
                      . (,(string-append
                           "https://download.racket-lang.org/releases/"