summary refs log tree commit diff
path: root/gnu/packages/rdf.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/rdf.scm')
-rw-r--r--gnu/packages/rdf.scm5
1 files changed, 4 insertions, 1 deletions
diff --git a/gnu/packages/rdf.scm b/gnu/packages/rdf.scm
index 19a68be229..e03f3d9e96 100644
--- a/gnu/packages/rdf.scm
+++ b/gnu/packages/rdf.scm
@@ -81,13 +81,16 @@ HTML and JSON.")
              (sha256
               (base32
                "1arffdwivig88kkx685pldr784njm0249k0rb1f1plwavlrw9zfx"))
-             (patches (list (search-patch "clucene-pkgconfig.patch")))))
+             (patches (list 
+                       (search-patch "clucene-pkgconfig.patch")
+                       (search-patch "clucene-contribs-lib.patch")))))
     (build-system cmake-build-system)
     (inputs
      `(("boost" ,boost) ; could also use bundled copy
        ("zlib" ,zlib)))
     (arguments
      `(#:test-target "cl_test"
+       #:configure-flags '("-DBUILD_CONTRIBS_LIB=ON")
        #:tests? #f)) ; Tests do not compile, as TestIndexSearcher.cpp uses
                      ; undeclared usleep. After fixing this, one needs to run
                      ; "make test" in addition to "make cl_test", then