summary refs log tree commit diff
path: root/gnu/packages/ruby.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/ruby.scm')
-rw-r--r--gnu/packages/ruby.scm33
1 files changed, 33 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index af7b1af4bb..35215cfc14 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -2895,6 +2895,39 @@ used to create both network servers and clients.")
     (home-page "http://rubyeventmachine.com")
     (license (list license:ruby license:gpl3)))) ; GPLv3 only AFAICT
 
+(define-public ruby-turn
+  (package
+    (name "ruby-turn")
+    (version "0.9.7")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (rubygems-uri "turn" version))
+       (sha256
+        (base32
+         "1691rc2sq04cw8mxxh340k2j04ll90kwgcy8ddrp6rligmfrf8fw"))))
+    (build-system ruby-build-system)
+    (arguments
+     `(#:phases
+       (modify-phases %standard-phases
+         ;; Tests fail because turn changes its environment so can no longer
+         ;; find test/unit.  Instead simply test if the executable runs
+         ;; without issue.
+         (replace 'check
+           (lambda _
+             (zero? (system* "ruby" "-Ilib" "bin/turn" "-h")))))))
+    (propagated-inputs
+     `(("ruby-ansi" ,ruby-ansi)
+       ("ruby-minitest" ,ruby-minitest-4)))
+    (synopsis "Alternate set of alternative runners for MiniTest")
+    (description
+     "TURN provides a set of alternative runners for MiniTest which are both
+colorful and informative.  TURN displays each test on a separate line with
+failures being displayed immediately instead of at the end of the tests.  Note
+that TURN is no longer being maintained.")
+    (home-page "http://rubygems.org/gems/turn")
+    (license license:expat)))
+
 (define-public ruby-ansi
   (package
     (name "ruby-ansi")