summary refs log tree commit diff
path: root/gnu/packages/ruby.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/ruby.scm')
-rw-r--r--gnu/packages/ruby.scm10
1 files changed, 9 insertions, 1 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index b8fa5a3ad9..6a2eece734 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -3029,7 +3029,15 @@ a native C extension.")
            (lambda _
              ;; Regenerate gemspec so loosened dependency constraints are
              ;; propagated.
-             (invoke "rake" "gemspec"))))))
+             (invoke "rake" "gemspec")))
+         (add-after 'regenerate-gemspec 'fix-json-java.gemspec
+           (lambda _
+             ;; This gemspec doesn't look to be generated by the above
+             ;; command, so patch it separately.
+             (substitute* "json-java.gemspec"
+               (("%q<test-unit>\\.freeze, \\[\"~> 2\\.0\"\\]")
+                "%q<test-unit>.freeze, [\">= 2.0\"]"))
+             #t)))))
     (native-inputs
      `(("bundler" ,bundler)
        ("ragel" ,ragel)