summary refs log tree commit diff
path: root/gnu/packages/rust-cbindgen.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/rust-cbindgen.scm')
-rw-r--r--gnu/packages/rust-cbindgen.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/rust-cbindgen.scm b/gnu/packages/rust-cbindgen.scm
index 043889ed3b..2f8fe40cd0 100644
--- a/gnu/packages/rust-cbindgen.scm
+++ b/gnu/packages/rust-cbindgen.scm
@@ -189,3 +189,24 @@ Command Line Argument Parser.")
 cryptographically secure pseudorandom number generator.")
     (properties '((hidden? . #t)))
     (license license:bsd-3)))
+
+(define rust-itoa-0.4
+  (package
+    (name "rust-itoa")
+    (version "0.4.4")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (crate-uri "itoa" version))
+        (file-name (string-append name "-" version ".crate"))
+        (sha256
+         (base32
+          "0zvg2d9qv3avhf3d8ggglh6fdyw8kkwqg3r4622ly5yhxnvnc4jh"))))
+    (build-system cargo-build-system)
+    (home-page "https://github.com/dtolnay/itoa")
+    (synopsis "Fast functions for printing integer primitives")
+    (description "This crate provides fast functions for printing integer
+primitives to an @code{io::Write}.")
+    (properties '((hidden? . #t)))
+    (license (list license:asl2.0
+                   license:expat))))