summary refs log tree commit diff
path: root/gnu/packages/rust.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/rust.scm')
-rw-r--r--gnu/packages/rust.scm12
1 files changed, 9 insertions, 3 deletions
diff --git a/gnu/packages/rust.scm b/gnu/packages/rust.scm
index 2942c5cb1f..25472fefb0 100644
--- a/gnu/packages/rust.scm
+++ b/gnu/packages/rust.scm
@@ -362,9 +362,15 @@ safety and thread safety guarantees.")
        (uri (rust-uri version))
        (sha256 (base32 "07l28f7grdmi65naq71pbmvdd61hwcpi40ry7kp7dy7m233rldxj"))
        (modules '((guix build utils)))
-       (snippet '(for-each delete-file-recursively
-                           '("src/llvm-project"
-                             "vendor/tikv-jemalloc-sys/jemalloc")))))
+       (snippet
+        '(begin
+           (for-each delete-file-recursively
+                     '("src/llvm-project"
+                       "vendor/tikv-jemalloc-sys/jemalloc"))
+           ;; Add support for riscv64-linux.
+           (substitute* "vendor/tikv-jemallocator/src/lib.rs"
+             (("    target_arch = \"s390x\"," all)
+              (string-append all "\n    target_arch = \"riscv64\",")))))))
     (outputs '("out" "cargo"))
     (properties '((timeout . 72000)           ;20 hours
                   (max-silent-time . 18000))) ;5 hours (for armel)