summary refs log tree commit diff
path: root/gnu/packages/samba.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/samba.scm')
-rw-r--r--gnu/packages/samba.scm28
1 files changed, 11 insertions, 17 deletions
diff --git a/gnu/packages/samba.scm b/gnu/packages/samba.scm
index 213e416a4d..5ddc8748f3 100644
--- a/gnu/packages/samba.scm
+++ b/gnu/packages/samba.scm
@@ -287,15 +287,9 @@ destructors.  It is the core memory allocator used in Samba.")
         `(modify-phases ,phases
            (replace 'build
              (lambda _
-               (letrec-syntax ((shell (syntax-rules ()
-                                        ((_ (command ...) rest ...)
-                                         (and (zero? (system* command ...))
-                                              (shell rest ...)))
-                                        ((_)
-                                         #t))))
-                 (shell ("gcc" "-c" "-Ibin/default" "-I" "lib/replace"
-                         "-I." "-Wall" "-g" "talloc.c")
-                        ("ar" "rc" "libtalloc.a" "talloc.o")))))
+               (invoke "gcc" "-c" "-Ibin/default" "-I" "lib/replace"
+                       "-I." "-Wall" "-g" "talloc.c")
+               (invoke "ar" "rc" "libtalloc.a" "talloc.o")))
            (replace 'install
              (lambda* (#:key outputs #:allow-other-keys)
                (let* ((out     (assoc-ref outputs "out"))
@@ -326,9 +320,9 @@ destructors.  It is the core memory allocator used in Samba.")
            ;; tevent uses a custom configuration script that runs waf.
            (lambda* (#:key outputs #:allow-other-keys)
              (let ((out (assoc-ref outputs "out")))
-               (zero? (system* "./configure"
-                               (string-append "--prefix=" out)
-                               "--bundled-libraries=NONE"))))))))
+               (invoke "./configure"
+                       (string-append "--prefix=" out)
+                       "--bundled-libraries=NONE")))))))
     (native-inputs
      `(("pkg-config" ,pkg-config)
        ("python" ,python-2)))
@@ -374,11 +368,11 @@ many event types, including timers, signals, and the classic file descriptor eve
            ;; ldb use a custom configuration script that runs waf.
            (lambda* (#:key outputs #:allow-other-keys)
              (let ((out (assoc-ref outputs "out")))
-               (zero? (system* "./configure"
-                               (string-append "--prefix=" out)
-                               (string-append "--with-modulesdir=" out
-                                              "/lib/ldb/modules")
-                               "--bundled-libraries=NONE"))))))))
+               (invoke "./configure"
+                       (string-append "--prefix=" out)
+                       (string-append "--with-modulesdir=" out
+                                      "/lib/ldb/modules")
+                       "--bundled-libraries=NONE")))))))
     (native-inputs
      `(("cmocka" ,cmocka)
        ("pkg-config" ,pkg-config)