summary refs log tree commit diff
path: root/gnu/packages/scheme.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/scheme.scm')
-rw-r--r--gnu/packages/scheme.scm39
1 files changed, 28 insertions, 11 deletions
diff --git a/gnu/packages/scheme.scm b/gnu/packages/scheme.scm
index 00b573fc0b..50533b9a29 100644
--- a/gnu/packages/scheme.scm
+++ b/gnu/packages/scheme.scm
@@ -2,6 +2,8 @@
 ;;; Copyright © 2013, 2014, 2015 Ludovic Courtès <ludo@gnu.org>
 ;;; Copyright © 2015 Taylan Ulrich Bayırlı/Kammer <taylanbayirli@gmail.com>
 ;;; Copyright © 2015 Federico Beffa <beffa@fbengineering.ch>
+;;; Copyright © 2016 Ricardo Wurmus <rekado@elephly.net>
+;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -35,6 +37,7 @@
   #:use-module (gnu packages pkg-config)
   #:use-module (gnu packages avahi)
   #:use-module (gnu packages libphidget)
+  #:use-module (gnu packages gcc)
   #:use-module (gnu packages glib)
   #:use-module (gnu packages gtk)
   #:use-module (gnu packages libffi)
@@ -309,14 +312,14 @@ mashups, office (web agendas, mail clients, ...), etc.")
 (define-public chicken
   (package
     (name "chicken")
-    (version "4.9.0.1")
+    (version "4.10.0")
     (source (origin
              (method url-fetch)
-             (uri (string-append "http://code.call-cc.org/releases/4.9.0/chicken-"
-                                 version ".tar.gz"))
+             (uri (string-append "http://code.call-cc.org/releases/"
+                                 version "/chicken-" version ".tar.gz"))
              (sha256
               (base32
-               "0598mar1qswfd8hva9nqs88zjn02lzkqd8fzdd21dz1nki1prpq4"))))
+               "16w96jrhb6qf62fgznk53f55yhfv81damghdjn31k5hirnmza1qf"))))
     (build-system gnu-build-system)
     (arguments
      `(#:modules ((guix build gnu-build-system)
@@ -325,11 +328,19 @@ mashups, office (web agendas, mail clients, ...), etc.")
 
        ;; No `configure' script; run "make check" after "make install" as
        ;; prescribed by README.
-       #:phases (alist-cons-after
-                 'install 'check
-                 (assoc-ref %standard-phases 'check)
-                 (fold alist-delete %standard-phases
-                       '(configure check)))
+       #:phases
+       (modify-phases %standard-phases
+         (delete 'configure)
+         (delete 'check)
+         (add-after 'install 'check
+           (assoc-ref %standard-phases 'check))
+         (add-after 'unpack 'disable-broken-tests
+           (lambda _
+             ;; The port tests fail with this error:
+             ;; Error: (line 294) invalid escape-sequence '\x o'
+             (substitute* "tests/runtests.sh"
+               (("\\$interpret -s port-tests\\.scm") ""))
+             #t)))
 
        #:make-flags (let ((out (assoc-ref %outputs "out")))
                       (list "PLATFORM=linux"
@@ -338,6 +349,12 @@ mashups, office (web agendas, mail clients, ...), etc.")
 
        ;; Parallel builds are not supported, as noted in README.
        #:parallel-build? #f))
+    ;; One of the tests ("testing direct invocation can detect calls of too
+    ;; many arguments...") times out when building with a more recent GCC.
+    ;; The problem was reported here:
+    ;; https://lists.gnu.org/archive/html/chicken-hackers/2015-04/msg00059.html
+    (native-inputs
+     `(("gcc" ,gcc-4.8)))
     (home-page "http://www.call-cc.org/")
     (synopsis "R5RS Scheme implementation that compiles native code via C")
     (description
@@ -349,14 +366,14 @@ language standard, and includes many enhancements and extensions.")
 (define-public scheme48
   (package
     (name "scheme48")
-    (version "1.9")
+    (version "1.9.2")
     (source (origin
              (method url-fetch)
              (uri (string-append "http://s48.org/" version
                                  "/scheme48-" version ".tgz"))
              (sha256
               (base32
-               "0rw2lz5xgld0klvld292ds6hvfk5l12vskzgf1hhwjdpa38r3fnw"))
+               "1x4xfm3lyz2piqcw1h01vbs1iq89zq7wrsfjgh3fxnlm1slj2jcw"))
              (patches (list (search-patch "scheme48-tests.patch")))))
     (build-system gnu-build-system)
     (home-page "http://s48.org/")