summary refs log tree commit diff
path: root/gnu/packages/shellutils.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/shellutils.scm')
-rw-r--r--gnu/packages/shellutils.scm9
1 files changed, 8 insertions, 1 deletions
diff --git a/gnu/packages/shellutils.scm b/gnu/packages/shellutils.scm
index 3f9f8a27f4..d0f4068062 100644
--- a/gnu/packages/shellutils.scm
+++ b/gnu/packages/shellutils.scm
@@ -341,7 +341,14 @@ between various shells or commands.")
                (mkdir-p bin)
                (substitute* "setup.py"
                  (("add_script\\('")
-                  (string-append "add_script('" bin "/" )))))))))
+                  (string-append "add_script('" bin "/" ))))))
+         ;; Whenever setup.py is invoked, scripts in out/bin/ are
+         ;; replaced. Thus we cannot invoke setup.py for testing.
+         ;; Upstream also uses pytest.
+         (replace 'check
+           (lambda* (#:key tests? #:allow-other-keys)
+             (when tests?
+               (invoke "pytest")))))))
     (native-inputs
      (list python-pytest
            python-mock