summary refs log tree commit diff
path: root/gnu/packages/skribilo.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/skribilo.scm')
-rw-r--r--gnu/packages/skribilo.scm29
1 files changed, 15 insertions, 14 deletions
diff --git a/gnu/packages/skribilo.scm b/gnu/packages/skribilo.scm
index 458d91e569..87dc3558de 100644
--- a/gnu/packages/skribilo.scm
+++ b/gnu/packages/skribilo.scm
@@ -46,20 +46,21 @@
                                               (assoc-ref %outputs "out")
                                               "/share/guile/site/2.0"))
 
-       #:phases (alist-cons-before
-                 'configure 'pre-configure
-                 (lambda* (#:key inputs #:allow-other-keys)
-                   ;; Make sure the 'skribilo' command gets to see
-                   ;; Guile-Reader, even if Guile-Reader is not in the search
-                   ;; path.
-                   (let ((reader (assoc-ref inputs "guile-reader")))
-                     (substitute* "src/skribilo.in"
-                       (("^exec (.*) -c" _ things)
-                        (string-append "exec " things
-                                       " -L " reader "/share/guile/site/2.0"
-                                       " -C " reader "/share/guile/site/2.0"
-                                       " -c")))))
-                 %standard-phases)
+       #:phases
+       (modify-phases %standard-phases
+         (add-before 'configure 'pre-configure
+           (lambda* (#:key inputs #:allow-other-keys)
+             ;; Make sure the 'skribilo' command gets to see
+             ;; Guile-Reader, even if Guile-Reader is not in the search
+             ;; path.
+             (let ((reader (assoc-ref inputs "guile-reader")))
+               (substitute* "src/skribilo.in"
+                 (("^exec (.*) -c" _ things)
+                  (string-append "exec " things
+                                 " -L " reader "/share/guile/site/2.0"
+                                 " -C " reader "/share/guile/site/2.0"
+                                 " -c"))))
+             #t)))
 
        #:parallel-build? #f))