summary refs log tree commit diff
path: root/gnu/packages/speech.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/speech.scm')
-rw-r--r--gnu/packages/speech.scm37
1 files changed, 36 insertions, 1 deletions
diff --git a/gnu/packages/speech.scm b/gnu/packages/speech.scm
index 66d8fca31b..687a3c10cf 100644
--- a/gnu/packages/speech.scm
+++ b/gnu/packages/speech.scm
@@ -7,6 +7,7 @@
 ;;; Copyright © 2019 Ricardo Wurmus <rekado@elephly.net>
 ;;; Copyright © 2020 Nicolas Goaziou <mail@nicolasgoaziou.fr>
 ;;; Copyright © 2020 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2021 qblade <qblade@protonmail.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -543,7 +544,7 @@ be used by the sighted.")
            (sha256
             (base32
              "1k2xh13miyv48gh06rgsq2vj25xwj7z6vwq9ilsn8i7ig3nrgzg4"))))))
-    (home-page "http://www.cstr.ed.ac.uk/projects/festival/")
+    (home-page "https://www.cstr.ed.ac.uk/projects/festival/")
     (synopsis "Speech synthesis system")
     (description "Festival offers a general framework for building speech
 synthesis systems as well as including examples of various modules.  As a
@@ -555,6 +556,40 @@ low level architecture and has a Scheme (SIOD) based command interpreter for
 control.")
     (license (license:non-copyleft "file://COPYING"))))
 
+(define-public ekho
+  (package
+    (name "ekho")
+    (version "8.4")
+    (source
+     (origin
+       (method url-fetch)
+       (uri
+        (string-append "mirror://sourceforge/e-guidedog/Ekho/"
+                       version "/ekho-" version ".tar.xz"))
+       (sha256
+        (base32 "1v476kpw09ljj8mavasj4hya2w11jwlx7q22rh1lsn9jkkam5i2a"))))
+    (native-inputs
+     `(("pkg-config" ,pkg-config)))
+    (inputs
+     `(("alsa-lib" ,alsa-lib)
+       ("espeak-ng" ,espeak-ng)
+       ("libsndfile" ,libsndfile)
+       ("pulseaudio" ,pulseaudio)))
+    (build-system gnu-build-system)
+    (native-search-paths
+     (list (search-path-specification
+            (variable "EKHO_DATA_PATH")
+            (files '("share/ekho-data")))))
+    (home-page "https://eguidedog.net/ekho.php")
+    (synopsis "Chinese text-to-speech software")
+    (description
+     "Ehko is a Text-To-Speech (TTS) software.  It supports Cantonese,
+Mandarin, Toisanese, Zhaoan Hakka, Tibetan, Ngangien and Korean (in trial).
+It can also speak English through eSpeak or Festival.")
+    (license (list license:gpl2+
+                   ;; libmusicxml
+                   license:mpl2.0))))
+
 (define-public sphinxbase
   (package
     (name "sphinxbase")