summary refs log tree commit diff
path: root/gnu/packages/spice.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/spice.scm')
-rw-r--r--gnu/packages/spice.scm20
1 files changed, 8 insertions, 12 deletions
diff --git a/gnu/packages/spice.scm b/gnu/packages/spice.scm
index d9daac1185..b21394ea8a 100644
--- a/gnu/packages/spice.scm
+++ b/gnu/packages/spice.scm
@@ -252,6 +252,14 @@ which allows users to view a desktop computing environment.")
         '("--enable-lz4"
           "--enable-automated-tests")
 
+        #:phases
+        (modify-phases %standard-phases
+          ;; XXX: Otherwise the server listen tests fails with
+          ;;   Failed to create /homeless-shelter/.config/glib-2.0/settings
+          (add-before 'check 'set-XDG_CONFIG_HOME
+            (lambda _
+              (setenv "XDG_CONFIG_HOME" "/tmp"))))
+
         ;; Several tests appear to be opening the same sockets concurrently.
         #:parallel-tests? #f))
     (synopsis "Server implementation of the SPICE protocol")
@@ -341,17 +349,6 @@ resolution scaling on graphical console window resize.")
                (base32
                 "0azj3rqr2smg0lai24xrn3zr628xmjfrzcggay877zrr64ybj1c0"))))
     (build-system meson-build-system)
-    (arguments
-     '(#:tests? #f                      ; TODO Tests require gnutls built with
-                                        ; p11-kit
-       #:phases
-       (modify-phases %standard-phases
-         (add-after 'unpack 'patch-tests
-           (lambda* (#:key inputs #:allow-other-keys)
-             (substitute* "tests/setup-softhsm2.sh"
-               (("\\/usr\\/lib64\\/pkcs11\\/libsofthsm2\\.so")
-                (string-append (assoc-ref inputs "softhsm")
-                               "/lib/softhsm/libsofthsm2.so"))))))))
     (propagated-inputs
      `(("glib" ,glib)                   ; Requires: in the pkg-config file
        ("nss" ,nss)                     ; Requires.private: in the pkg-config
@@ -360,7 +357,6 @@ resolution scaling on graphical console window resize.")
      `(("openssl" ,openssl)
        ("nss" ,nss "bin")
        ("opensc" ,opensc)
-       ("softhsm" ,softhsm)
        ("gnutls" ,gnutls)
        ("pkg-config" ,pkg-config)
        ("which" ,which)))