summary refs log tree commit diff
path: root/gnu/packages/ssh.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/ssh.scm')
-rw-r--r--gnu/packages/ssh.scm7
1 files changed, 5 insertions, 2 deletions
diff --git a/gnu/packages/ssh.scm b/gnu/packages/ssh.scm
index 78611b1767..837d616c21 100644
--- a/gnu/packages/ssh.scm
+++ b/gnu/packages/ssh.scm
@@ -108,8 +108,11 @@ remote applications.")
             (sha256 (base32
                      "0vdr478dbhbdgnniqmirawjb7mrcxckn4slhhrijxnzrkmgziipa"))))
    (build-system gnu-build-system)
-   (inputs `(("libgcrypt" ,libgcrypt)
-             ("zlib" ,zlib)))
+   ;; The installed libssh2.pc file does not include paths to libgcrypt and
+   ;; zlib libraries, so we need to propagate the inputs.
+   (propagated-inputs `(("libgcrypt" ,libgcrypt)
+                        ("zlib" ,zlib)))
+   (arguments '(#:configure-flags `("--with-libgcrypt")))
    (synopsis "libssh2, a client-side C library implementing the SSH2 protocol")
    (description
     "libssh2 is a library intended to allow software developers access to