summary refs log tree commit diff
path: root/gnu/packages/ssh.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/ssh.scm')
-rw-r--r--gnu/packages/ssh.scm9
1 files changed, 9 insertions, 0 deletions
diff --git a/gnu/packages/ssh.scm b/gnu/packages/ssh.scm
index 16cd6e20d8..b2612a495f 100644
--- a/gnu/packages/ssh.scm
+++ b/gnu/packages/ssh.scm
@@ -139,10 +139,19 @@ a server that supports the SSH-2 protocol.")
    (build-system gnu-build-system)
    (inputs `(("groff" ,groff)
              ("openssl" ,openssl)
+             ("pam" ,linux-pam)
              ("zlib" ,zlib)
              ("xauth" ,xauth)))                   ;for 'ssh -X' and 'ssh -Y'
    (arguments
     `(#:test-target "tests"
+      #:configure-flags '("--sysconfdir=/etc"
+
+                          ;; Default value of 'PATH' used by sshd.
+                          "--with-default-path=/run/current-system/profile/bin"
+
+                          ;; Enable PAM support in sshd.
+                          "--with-pam")
+
       #:phases
       (modify-phases %standard-phases
         (add-after 'configure 'reset-/var/empty