summary refs log tree commit diff
path: root/gnu/packages/ssh.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/ssh.scm')
-rw-r--r--gnu/packages/ssh.scm9
1 files changed, 5 insertions, 4 deletions
diff --git a/gnu/packages/ssh.scm b/gnu/packages/ssh.scm
index 10697850f4..29251291dc 100644
--- a/gnu/packages/ssh.scm
+++ b/gnu/packages/ssh.scm
@@ -122,7 +122,7 @@ a server that supports the SSH-2 protocol.")
 (define-public openssh
   (package
    (name "openssh")
-   (version "6.7p1")
+   (version "6.8p1")
    (source (origin
             (method url-fetch)
             (uri (let ((tail (string-append name "-" version ".tar.gz")))
@@ -131,7 +131,7 @@ a server that supports the SSH-2 protocol.")
                          (string-append "ftp://ftp2.fr.openbsd.org/pub/OpenBSD/OpenSSH/portable/"
                                         tail))))
             (sha256 (base32
-                     "01smf9pvn2sk5qs80gkmc9acj07ckawi1b3xxyysp3c5mr73ky5j"))))
+                     "03hnrqvjq6ghg1mp3gkarfxh6g3x1n1vjrzpbc5lh9717vklrxiz"))))
    (build-system gnu-build-system)
    (inputs `(("groff" ,groff)
              ("openssl" ,openssl)
@@ -149,9 +149,10 @@ a server that supports the SSH-2 protocol.")
        (alist-cons-before
         'check 'patch-tests
         (lambda _
-          ;; remove tests that require the user sshd
+          ;; remove 't-exec' regress target which requires user 'sshd'
           (substitute* "regress/Makefile"
-            (("t10 t-exec") "t10")))
+            (("^(REGRESS_TARGETS=.*) t-exec(.*)" all pre post)
+             (string-append pre post))))
        (alist-replace
         'install
         (lambda* (#:key (make-flags '()) #:allow-other-keys)