summary refs log tree commit diff
path: root/gnu/packages/sssd.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/sssd.scm')
-rw-r--r--gnu/packages/sssd.scm9
1 files changed, 2 insertions, 7 deletions
diff --git a/gnu/packages/sssd.scm b/gnu/packages/sssd.scm
index 6d6caab0ad..7bb71dce13 100644
--- a/gnu/packages/sssd.scm
+++ b/gnu/packages/sssd.scm
@@ -81,15 +81,14 @@ fundamental object types for C.")
 (define-public sssd
   (package
     (name "sssd")
-    (version "1.16.2")
+    (version "1.16.4")
     (source (origin
               (method url-fetch)
               (uri (string-append "http://releases.pagure.org/SSSD/sssd/"
                                   "sssd-" version ".tar.gz"))
-              (patches (search-patches "sssd-curl-compat.patch"))
               (sha256
                (base32
-                "032ppk57qs1lnvz7pb7lw9ldwm9i1yagh9fzgqgn6na3bg61ynzy"))))
+                "0ngr7cgimyjc6flqkm7psxagp1m4jlzpqkn28pliifbmdg6i5ckb"))))
     (build-system gnu-build-system)
     (arguments
      `(#:make-flags
@@ -130,10 +129,6 @@ fundamental object types for C.")
            (lambda _
              (substitute* "src/tests/responder_socket_access-tests.c"
                (("tcase_add_test\\(tc_utils, resp_str_to_array_test\\);") ""))
-             ;; XXX: These tests fail with recent versions of ldb.  See
-             ;; <https://pagure.io/SSSD/sssd/issue/3563>.
-             (substitute* "Makefile.in"
-               (("sysdb-tests\\$\\(EXEEXT\\)") ""))
              #t)))))
     (inputs
      `(("augeas" ,augeas)