summary refs log tree commit diff
path: root/gnu/packages/statistics.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/statistics.scm')
-rw-r--r--gnu/packages/statistics.scm8
1 files changed, 8 insertions, 0 deletions
diff --git a/gnu/packages/statistics.scm b/gnu/packages/statistics.scm
index ee6e69346a..4df1e2457a 100644
--- a/gnu/packages/statistics.scm
+++ b/gnu/packages/statistics.scm
@@ -118,6 +118,13 @@ be output in text, PostScript, PDF or HTML.")
                             "/lib/R/lib"))
        #:phases
        (modify-phases %standard-phases
+         (add-before 'configure 'patch-uname
+           (lambda* (#:key inputs #:allow-other-keys)
+             (let ((uname-bin (string-append (assoc-ref inputs "coreutils")
+                                             "/bin/uname")))
+               (substitute* "src/scripts/R.sh.in"
+                 (("uname") uname-bin)))
+             #t))
          (add-before
           'configure 'set-default-pager
           ;; Set default pager to "cat", because otherwise it is "false",
@@ -170,6 +177,7 @@ be output in text, PostScript, PDF or HTML.")
      `(;; We need not only cairo here, but pango to ensure that tests for the
        ;; "cairo" bitmapType plotting backend succeed.
        ("pango" ,pango)
+       ("coreutils" ,coreutils)
        ("curl" ,curl)
        ("tzdata" ,tzdata)
        ("openblas" ,openblas)