summary refs log tree commit diff
path: root/gnu/packages/statistics.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/statistics.scm')
-rw-r--r--gnu/packages/statistics.scm5
1 files changed, 3 insertions, 2 deletions
diff --git a/gnu/packages/statistics.scm b/gnu/packages/statistics.scm
index 75bdb5df83..49bb24e594 100644
--- a/gnu/packages/statistics.scm
+++ b/gnu/packages/statistics.scm
@@ -113,7 +113,8 @@ be output in text, PostScript, PDF or HTML.")
                 "0v7wpj89b0i3ad3fi1wak5c93hywmbxv8sdnixhq8l17782nidss"))))
     (build-system gnu-build-system)
     (arguments
-     `(#:make-flags
+     `(#:disallowed-references (,tzdata-2017a)
+       #:make-flags
        (list (string-append "LDFLAGS=-Wl,-rpath="
                             (assoc-ref %outputs "out")
                             "/lib/R/lib")
@@ -187,6 +188,7 @@ be output in text, PostScript, PDF or HTML.")
        ("pkg-config" ,pkg-config)
        ("texinfo" ,texinfo) ; for building HTML manuals
        ("which" ,which) ; for tests/Examples/base-Ex.R
+       ("tzdata" ,tzdata-2017a)
        ("xz" ,xz)))
     (inputs
      `(;; We need not only cairo here, but pango to ensure that tests for the
@@ -194,7 +196,6 @@ be output in text, PostScript, PDF or HTML.")
        ("pango" ,pango)
        ("coreutils" ,coreutils)
        ("curl" ,curl)
-       ("tzdata" ,tzdata)
        ("openblas" ,openblas)
        ("gfortran" ,gfortran)
        ("icu4c" ,icu4c)