summary refs log tree commit diff
path: root/gnu/packages/sxiv.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/sxiv.scm')
-rw-r--r--gnu/packages/sxiv.scm62
1 files changed, 0 insertions, 62 deletions
diff --git a/gnu/packages/sxiv.scm b/gnu/packages/sxiv.scm
deleted file mode 100644
index 8a81d48f3e..0000000000
--- a/gnu/packages/sxiv.scm
+++ /dev/null
@@ -1,62 +0,0 @@
-;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2015, 2016 Alex Kost <alezost@gmail.com>
-;;;
-;;; This file is part of GNU Guix.
-;;;
-;;; GNU Guix is free software; you can redistribute it and/or modify it
-;;; under the terms of the GNU General Public License as published by
-;;; the Free Software Foundation; either version 3 of the License, or (at
-;;; your option) any later version.
-;;;
-;;; GNU Guix is distributed in the hope that it will be useful, but
-;;; WITHOUT ANY WARRANTY; without even the implied warranty of
-;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
-;;; GNU General Public License for more details.
-;;;
-;;; You should have received a copy of the GNU General Public License
-;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.
-
-(define-module (gnu packages sxiv)
-  #:use-module (guix packages)
-  #:use-module (guix download)
-  #:use-module (guix build-system gnu)
-  #:use-module ((guix licenses) #:prefix license:)
-  #:use-module (gnu packages xorg)
-  #:use-module (gnu packages image)
-  #:use-module (gnu packages photo))
-
-(define-public sxiv
-  (package
-    (name "sxiv")
-    (version "1.3.2")
-    (source (origin
-              (method url-fetch)
-              (uri (string-append
-                    "https://github.com/muennich/sxiv/archive/v"
-                    version ".tar.gz"))
-              (file-name (string-append name "-" version ".tar.gz"))
-              (sha256
-               (base32
-                "0lxnd33gaw4drhdwbkk94wzrjyhh64d57jq2ps7ffmqgizg6hlwz"))))
-    (build-system gnu-build-system)
-    (arguments
-     '(#:tests? #f                      ; no check target
-       #:make-flags (list (string-append "PREFIX=" %output)
-                          "CC=gcc")
-       #:phases (alist-delete
-                 'configure             ; no configure phase
-                 %standard-phases)))
-    (inputs
-     `(("libx11" ,libx11)
-       ("imlib2" ,imlib2)
-       ("giflib" ,giflib)
-       ("libexif" ,libexif)))
-    (home-page "https://github.com/muennich/sxiv")
-    (synopsis "Simple X Image Viewer")
-    (description
-     "sxiv is an alternative to feh and qiv.  Its primary goal is to
-provide the most basic features required for fast image viewing.  It has
-vi key bindings and works nicely with tiling window managers.  Its code
-base should be kept small and clean to make it easy for you to dig into
-it and customize it for your needs.")
-    (license license:gpl2+)))