summary refs log tree commit diff
path: root/gnu/packages/sync.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/sync.scm')
-rw-r--r--gnu/packages/sync.scm24
1 files changed, 18 insertions, 6 deletions
diff --git a/gnu/packages/sync.scm b/gnu/packages/sync.scm
index 1c80b7978e..b3305be6ba 100644
--- a/gnu/packages/sync.scm
+++ b/gnu/packages/sync.scm
@@ -183,8 +183,20 @@ their folder.
        #:test-target "tests"
        #:phases
        (modify-phases %standard-phases
-         ;; No install target.
+         (add-after 'unpack 'search-$PATH-for-binaries
+           ;; lsyncd requires and hard-codes absolute file names to binaries.
+           ;; Make it fall back to searching $PATH for relative file names.
+           (lambda _
+             (substitute* "lsyncd.c"
+               (("execv\\(") "execvp("))
+             (substitute* (list "lsyncd.lua"
+                                "default-direct.lua"
+                                "default-rsync.lua"
+                                "default-rsyncssh.lua")
+               (("(|/usr)/bin/") ""))
+             #t))
          (replace 'install
+           ;; No install target.
            (lambda* (#:key outputs #:allow-other-keys)
              (let* ((out (assoc-ref outputs "out"))
                     (bin (string-append out "/bin"))
@@ -252,19 +264,19 @@ over the Internet in an HTTP and CDN friendly way;
 (define-public rclone
   (package
     (name "rclone")
-    (version "1.48.0")
+    (version "1.49.4")
     (source
      (origin
        (method url-fetch)
-       (uri (string-append "https://github.com/ncw/rclone/releases/download/v"
-                           version "/rclone-v" version ".tar.gz"))
+       (uri (string-append "https://github.com/rclone/rclone/releases/download/"
+                           "v" version "/rclone-v" version ".tar.gz"))
        (sha256
-        (base32 "1r03rlsk0qpya1fl8xfhj5inccjywf2cqgkd8r6wfhf3w2qd1zlc"))))
+        (base32 "1bs7b3iy39igli1jqrgjzh32zzzhp1yj8rybsx8i34p9wj2zq2h7"))))
     ;; FIXME: Rclone bundles some libraries Guix already provides.  Need to
     ;; un-bundle them.
     (build-system go-build-system)
     (arguments
-     '(#:import-path "github.com/ncw/rclone"
+     '(#:import-path "github.com/rclone/rclone"
        #:install-source? #f))
     (synopsis "@code{rsync} for cloud storage")
     (description "@code{Rclone} is a command line program to sync files and