summary refs log tree commit diff
path: root/gnu/packages/sync.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/sync.scm')
-rw-r--r--gnu/packages/sync.scm14
1 files changed, 10 insertions, 4 deletions
diff --git a/gnu/packages/sync.scm b/gnu/packages/sync.scm
index d36e200def..ad264a0fe3 100644
--- a/gnu/packages/sync.scm
+++ b/gnu/packages/sync.scm
@@ -311,14 +311,14 @@ See also: megacmd, the official tool set by MEGA.")
 (define-public owncloud-client
   (package
     (name "owncloud-client")
-    (version "2.7.6.3261")
+    (version "2.9.0.5150")
     (source
      (origin
        (method url-fetch)
        (uri (string-append "https://download.owncloud.com/desktop/ownCloud/stable/"
                            version "/source/ownCloud-" version ".tar.xz"))
        (sha256
-        (base32 "19jjlhbzhy4v5h1wj5a87ismxq2p7avb2bb4lfbh2rvl01r432vy"))
+        (base32 "0nf68x840p30yng4fh1nlyiqg40z0rkcv0lskpz8dd4pj1iw5jjs"))
        (patches (search-patches "owncloud-disable-updatecheck.patch"))))
     ;; TODO: unbundle qprogessindicator, qlockedfile, qtokenizer and
     ;; qtsingleapplication which have not yet been packaged, but all are
@@ -340,10 +340,16 @@ See also: megacmd, the official tool set by MEGA.")
                (("QCoreApplication::applicationFilePath\\()") "\"owncloud\""))
              #t))
          (delete 'patch-dot-desktop-files))
-       #:configure-flags '("-DUNIT_TESTING=ON"
+       #:configure-flags `("-DUNIT_TESTING=ON"
                            ;; build without qtwebkit, which causes the
                            ;; package to FTBFS while looking for QWebView.
-                           "-DNO_SHIBBOLETH=1")))
+                           "-DNO_SHIBBOLETH=1"
+                           ;; Fix sync-exclude.list problem, see
+                           ;; <https://github.com/owncloud/client/issues/8373>
+                           ;; <https://issues.guix.gnu.org/47672>
+                           ,(string-append "-DSYSCONF_INSTALL_DIR="
+                                           (assoc-ref %outputs "out")
+                                           "/etc"))))
     (native-inputs
      `(("cmocka" ,cmocka)
        ("extra-cmake-modules" ,extra-cmake-modules)