summary refs log tree commit diff
path: root/gnu/packages/syncthing.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/syncthing.scm')
-rw-r--r--gnu/packages/syncthing.scm32
1 files changed, 14 insertions, 18 deletions
diff --git a/gnu/packages/syncthing.scm b/gnu/packages/syncthing.scm
index 5cb8449e44..4deb60bee2 100644
--- a/gnu/packages/syncthing.scm
+++ b/gnu/packages/syncthing.scm
@@ -45,9 +45,9 @@
 (define-public syncthing
   (package
     (name "syncthing")
-    (version "1.15.1")
+    (version "1.16.1")
     ; XXX After the go-build-system can use "Go modules", stop using bundled
-    ; dependenices for Syncthing.
+    ; dependencies for Syncthing.
     (source (origin
               (method url-fetch)
               (uri (string-append "https://github.com/syncthing/syncthing"
@@ -55,11 +55,11 @@
                                   "/syncthing-source-v" version ".tar.gz"))
               (sha256
                (base32
-                "04b90zwinl7frxrpjliq41mkbhpnkszmhdc5j2vbqwyhd82warxq"))))
+                "0m5k37sp3px8acs3y9an5wzy1wbcbdvqq74jy0pwzfk4bjbr999j"))))
     (build-system go-build-system)
     ;; The primary Syncthing executable goes to "out", while the auxiliary
     ;; server programs and utility tools go to "utils".  This reduces the size
-    ;; of "out" by ~80 MiB.
+    ;; of "out" by ~144 MiB.
     (outputs '("out" "utils"))
     (arguments
      `(#:modules ((srfi srfi-26) ; for cut
@@ -76,14 +76,6 @@
                (("120s") "999s"))
              #t))
 
-         (add-before 'build 'pre-build
-           (lambda _
-             (with-directory-excursion "src/github.com/syncthing/syncthing"
-               ;; Don't set a local GOBIN, it breaks cross compiling.
-               (substitute* "build.go"
-                 ((".*GOBIN.*") "")))
-             #t))
-
          (replace 'build
            (lambda _
              (with-directory-excursion "src/github.com/syncthing/syncthing"
@@ -92,7 +84,7 @@
                ;; "build syncthing" again with -no-upgrade.
                ;; https://github.com/syncthing/syncthing/issues/6118
                (invoke "go" "run" "build.go")
-               (for-each delete-file (find-files "../../../../bin" "syncthing"))
+               (delete-file "bin/syncthing")
                (invoke "go" "run" "build.go" "-no-upgrade" "build" "syncthing"))))
 
          (replace 'check
@@ -106,11 +98,15 @@
            (lambda* (#:key outputs #:allow-other-keys)
              (let ((out (assoc-ref outputs "out"))
                    (utils (assoc-ref outputs "utils")))
-               (with-directory-excursion "src/github.com/syncthing/syncthing"
-                 (install-file "syncthing" (string-append out "/bin")))
-               (for-each (cut install-file <> (string-append utils "/bin/"))
-                         (find-files "bin"))
-               #t)))
+               (with-directory-excursion "src/github.com/syncthing/syncthing/bin"
+                 (install-file "../syncthing" (string-append out "/bin"))
+                 (for-each (cut install-file <> (string-append utils "/bin/"))
+                           '("stcompdirs" "stcrashreceiver"
+                             "stdisco" "stdiscosrv" "stevents" "stfileinfo"
+                             "stfinddevice" "stfindignored" "stgenfiles"
+                             "strelaypoolsrv" "strelaysrv" "stsigtool"
+                             "stvanity" "stwatchfile" "uraggregate" "ursrv"))
+                 #t))))
 
          (add-after 'install 'install-docs
            (lambda* (#:key outputs #:allow-other-keys)