summary refs log tree commit diff
path: root/gnu/packages/syndication.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/syndication.scm')
-rw-r--r--gnu/packages/syndication.scm11
1 files changed, 5 insertions, 6 deletions
diff --git a/gnu/packages/syndication.scm b/gnu/packages/syndication.scm
index 732f5f4ea9..05e4c20d97 100644
--- a/gnu/packages/syndication.scm
+++ b/gnu/packages/syndication.scm
@@ -524,14 +524,13 @@ parser.  It is \"not fit for use at this point\", but gfeeds uses it anyway.")
     (name "gfeeds")
     (version "0.16.2")
     (source (origin
-              (method url-fetch)
-              (uri
-               (string-append
-                "https://gitlab.gnome.org/World/gfeeds/-/archive/" version
-                "/gfeeds-" version ".tar.bz2"))
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://gitlab.gnome.org/World/gfeeds")
+                    (commit version)))
               (sha256
                (base32
-                "05gwwzqfz29m477imd5vh84jfla1wnklwpc2sdxnqli72wg08fli"))))
+                "045889417506w2l25j7jxx7jfdpfljbirhm1s4whvhk83xap19zb"))))
     (build-system meson-build-system)
     (arguments
      `(#:phases