summary refs log tree commit diff
path: root/gnu/packages/telegram.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/telegram.scm')
-rw-r--r--gnu/packages/telegram.scm107
1 files changed, 57 insertions, 50 deletions
diff --git a/gnu/packages/telegram.scm b/gnu/packages/telegram.scm
index af90fc35eb..7d02824efa 100644
--- a/gnu/packages/telegram.scm
+++ b/gnu/packages/telegram.scm
@@ -4,6 +4,7 @@
 ;;; Copyright © 2023 Saku Laesvuori <saku@laesvuori.fi>
 ;;; Copyright © 2023 Lu Hui <luhux76@gmail.com>
 ;;; Copyright © 2023 Camilo Q.S. (Distopico) <distopico@riseup.net>
+;;; Copyright © 2024 Ricardo Wurmus <rekado@elephly.net>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -613,47 +614,50 @@ formerly a part of telegram-cli, but now being maintained separately.")
           (base32 "0cf5s7ygslb5klg1qv9qdc3hivhspmvh3zkacyyhd2yyikb5p0f9"))))
       (build-system gnu-build-system)
       (arguments
-       `(#:tests? #f                    ; No target
+       (list
+        #:tests? #f                    ; No target
          #:imported-modules
-         ((guix build copy-build-system)
-          ,@%gnu-build-system-modules)
+         `((guix build copy-build-system)
+           ,@%gnu-build-system-modules)
          #:modules
-         (((guix build copy-build-system)
-           #:prefix copy:)
-          (guix build gnu-build-system)
-          (guix build utils))
+         '(((guix build copy-build-system)
+            #:prefix copy:)
+           (guix build gnu-build-system)
+           (guix build utils))
          #:configure-flags
-         (list
-          ;; Use gcrypt instead of openssl.
-          "--disable-openssl"
-          ;; Enable extended queries system.
-          "--enable-extf"
-          ;; Include libevent-based net and timers.
-          "--enable-libevent")
+         '(list
+           ;; Use gcrypt instead of openssl.
+           "--disable-openssl"
+           ;; Enable extended queries system.
+           "--enable-extf"
+           ;; Include libevent-based net and timers.
+           "--enable-libevent")
          #:phases
-         (modify-phases %standard-phases
-           (add-after 'unpack 'trigger-bootstrap
-             (lambda _
-               (delete-file "configure")
-               #t))
-           (add-after 'trigger-bootstrap 'patch-tl-parser
-             (lambda _
-               (delete-file "Makefile.tl-parser")
-               (substitute* "Makefile.in"
-                 (("include \\$\\{srcdir\\}/Makefile\\.tl-parser")
-                  "")
-                 (("\\$\\{EXE\\}/tl-parser")
-                  "tl-parser"))
-               #t))
-           (replace 'install
-             (lambda args
-               (apply (assoc-ref copy:%standard-phases 'install)
-                      #:install-plan
-                      '(("bin" "bin")
-                        ("." "include/tgl"
-                         #:include-regexp ("\\.h$"))
-                        ("libs" "lib/tgl"))
-                      args))))))
+         '(modify-phases %standard-phases
+            (add-after 'unpack 'trigger-bootstrap
+              (lambda _
+                (delete-file "configure")))
+            (add-after 'trigger-bootstrap 'patch-tl-parser
+              (lambda _
+                (delete-file "Makefile.tl-parser")
+                (substitute* "Makefile.in"
+                  (("include \\$\\{srcdir\\}/Makefile\\.tl-parser")
+                   "")
+                  (("\\$\\{EXE\\}/tl-parser")
+                   "tl-parser"))))
+            (add-after 'unpack 'remove-Werror
+              (lambda _
+                (substitute* "Makefile.in"
+                  (("-Werror") ""))))
+            (replace 'install
+              (lambda args
+                (apply (assoc-ref copy:%standard-phases 'install)
+                       #:install-plan
+                       '(("bin" "bin")
+                         ("." "include/tgl"
+                          #:include-regexp ("\\.h$"))
+                         ("libs" "lib/tgl"))
+                       args))))))
       (native-inputs
        (list autoconf automake libtool pkg-config))
       (inputs
@@ -683,25 +687,29 @@ formerly a part of telegram-cli, but now being maintained separately.")
           (base32 "0c1w7jgska71jjbvg1y09v52549pwa4zkdjly18yxywn7gayd2p6"))))
       (build-system gnu-build-system)
       (arguments
-       `(#:tests? #f                    ; No target
-         #:imported-modules
-         ((guix build copy-build-system)
+       (list
+        #:tests? #f                     ; No target
+        #:imported-modules
+        `((guix build copy-build-system)
           ,@%gnu-build-system-modules)
-         #:modules
-         (((guix build copy-build-system)
+        #:modules
+        '(((guix build copy-build-system)
            #:prefix copy:)
           (guix build gnu-build-system)
           (guix build utils))
-         #:configure-flags
-         (list
+        #:configure-flags
+        '(list
           ;; Use gcrypt instead of openssl.
           "--disable-openssl")
-         #:phases
-         (modify-phases %standard-phases
+        #:phases
+        '(modify-phases %standard-phases
+           (add-after 'unpack 'remove-Werror
+             (lambda _
+               (substitute* "Makefile.in"
+                 (("-Werror") "-fcommon"))))
            (add-after 'unpack 'trigger-bootstrap
              (lambda _
-               (delete-file "configure")
-               #t))
+               (delete-file "configure")))
            (add-after 'trigger-bootstrap 'patch-tgl-and-tlparser
              (lambda* (#:key inputs #:allow-other-keys)
                (for-each delete-file
@@ -721,8 +729,7 @@ formerly a part of telegram-cli, but now being maintained separately.")
                                  "/include/tgl/auto"))
                  (("LIB=libs")
                   (string-append "LIB=" (assoc-ref inputs "tgl")
-                                 "/lib/tgl")))
-               #t))
+                                 "/lib/tgl")))))
            (replace 'install
              (lambda args
                (apply (assoc-ref copy:%standard-phases 'install)