summary refs log tree commit diff
path: root/gnu/packages/terminals.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/terminals.scm')
-rw-r--r--gnu/packages/terminals.scm14
1 files changed, 8 insertions, 6 deletions
diff --git a/gnu/packages/terminals.scm b/gnu/packages/terminals.scm
index 5bea5ab536..97dd0a82bd 100644
--- a/gnu/packages/terminals.scm
+++ b/gnu/packages/terminals.scm
@@ -88,7 +88,7 @@ configureable through a graphical wizard.")
 (define-public termite
   (package
     (name "termite")
-    (version "11")
+    (version "12")
     (source
       (origin
         (method git-fetch)
@@ -99,11 +99,13 @@ configureable through a graphical wizard.")
               (recursive? #t)))
         (file-name (string-append name "-" version "-checkout"))
         (sha256
-          (base32
-            "1cw4yw7n9m2si8b7zcfyz9pyihncabxm5g39v1mxslfajxgwzmd8"))))
+         (base32
+          "0s6dyg3vcqk5qcx90bs24wdnd3p56rdjdcanx4pcxvp6ksjl61jz"))))
     (build-system gnu-build-system)
     (arguments
-      `(#:phases (alist-delete 'configure %standard-phases)
+      `(#:phases
+        (modify-phases %standard-phases
+          (delete 'configure))
         #:tests? #f
         ;; This sets the destination when installing the necessary terminal
         ;; capability data, which are not provided by 'ncurses'.  See
@@ -263,7 +265,7 @@ multi-seat support, a replacement for @command{mingetty}, and more.")
 (define-public picocom
   (package
     (name "picocom")
-    (version "2.1")
+    (version "2.2")
     (source (origin
               (method url-fetch)
               (uri (string-append
@@ -272,7 +274,7 @@ multi-seat support, a replacement for @command{mingetty}, and more.")
               (file-name (string-append name "-" version ".tar.gz"))
               (sha256
                (base32
-                "1v891cx18vx3lnpfaq90f5y6njgigkn4qsikhrmyzshnz32jy5bb"))))
+                "1knl6dglnrynx1fhy21nylw56i1q3dkizkgxzkq42mb7ilah8f9y"))))
     (build-system gnu-build-system)
     (arguments
      `(#:make-flags '("CC=gcc")