summary refs log tree commit diff
path: root/gnu/packages/tex.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/tex.scm')
-rw-r--r--gnu/packages/tex.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index e17ddb2e91..a8bf38685b 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -29780,6 +29780,28 @@ University to write coursework more efficiently.  It can also be used by
 students from other universities.")
     (license license:lppl1.3+)))
 
+(define-public texlive-thuthesis
+  (package
+    (name "texlive-thuthesis")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "bibtex/bst/thuthesis/"
+                   "doc/latex/thuthesis/"
+                   "source/latex/thuthesis/"
+                   "tex/latex/thuthesis/")
+             (base32
+              "11l434c6v0sdhk4y776nrswj53sj2hba4i3dwbspgkh61ckxxhyx")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (home-page "https://ctan.org/pkg/thuthesis")
+    (synopsis "Thesis template for Tsinghua University")
+    (description
+     "This package establishes a simple and easy-to-use LaTeX template for
+Tsinghua dissertations, including general undergraduate research papers,
+masters theses, doctoral dissertations, and postdoctoral reports.")
+    (license license:lppl1.3c)))
+
 (define-public texlive-tinos
   (package
     (name "texlive-tinos")