summary refs log tree commit diff
path: root/gnu/packages/tex.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/tex.scm')
-rw-r--r--gnu/packages/tex.scm25
1 files changed, 24 insertions, 1 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 794756356e..9691fdeb71 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -38989,7 +38989,7 @@ considered as word, header etc.")
               "03y05mv0n04hyj0lcq54grx7w5wv95h61j6xlx2jc9v0ib9akq4y")))
     (outputs '("out" "doc"))
     (build-system texlive-build-system)
-    (propagated-inputs (list texlive-kpathsea))
+    (propagated-inputs (list texlive-kpathsea texlive-patgen-bin))
     (home-page "https://ctan.org/pkg/patgen")
     (synopsis "Generate hyphenation patterns")
     (description
@@ -38997,6 +38997,29 @@ considered as word, header etc.")
 that can be used by the TeX 82 hyphenation algorithm.")
     (license license:public-domain)))
 
+(define-public texlive-patgen-bin
+  (package
+    (inherit texlive-bin)
+    (name "texlive-patgen-bin")
+    (arguments
+     (substitute-keyword-arguments (package-arguments texlive-bin)
+       ((#:configure-flags flags)
+        #~(delete "--enable-web2c" #$flags))
+       ((#:phases phases)
+        #~(modify-phases #$phases
+            (replace 'install
+              (lambda _
+                (with-directory-excursion "texk/web2c"
+                  (invoke "make" "patgen")
+                  (install-file "patgen"
+                                (string-append #$output "/bin")))))))))
+    (native-inputs (list pkg-config))
+    (home-page (package-home-page texlive-patgen))
+    (synopsis "Binary for @code{texlive-patgen}")
+    (description
+     "This package provides the binary for @code{texlive-patgen}.")
+    (license (package-license texlive-patgen))))
+
 (define-public texlive-pdfbook2
   (package
     (name "texlive-pdfbook2")