summary refs log tree commit diff
path: root/gnu/packages/tex.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/tex.scm')
-rw-r--r--gnu/packages/tex.scm10
1 files changed, 6 insertions, 4 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 69dac602c8..4e8efc8faf 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -162,10 +162,12 @@
          "--with-system-zlib"
          "--with-system-zziplib")
 
-      ;; Disable tests on mips64 to cope with a failure of luajiterr.test.
-      ;; XXX FIXME fix luajit properly on mips64.
-      #:tests? ,(not (string-prefix? "mips64" (or (%current-target-system)
-                                                  (%current-system))))
+      ;; Disable tests on mips64/aarch64 to cope with a failure of luajiterr.test.
+      ;; XXX FIXME fix luajit properly on mips64 and aarch64.
+      #:tests? ,(let ((s (or (%current-target-system)
+                             (%current-system))))
+                  (not (or (string-prefix? "aarch64" s)
+                           (string-prefix? "mips64" s))))
       #:phases
        (modify-phases %standard-phases
          (add-after 'install 'postint