summary refs log tree commit diff
path: root/gnu/packages/textutils.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/textutils.scm')
-rw-r--r--gnu/packages/textutils.scm26
1 files changed, 13 insertions, 13 deletions
diff --git a/gnu/packages/textutils.scm b/gnu/packages/textutils.scm
index 151add964e..fb8bc7e868 100644
--- a/gnu/packages/textutils.scm
+++ b/gnu/packages/textutils.scm
@@ -79,25 +79,24 @@
 (define-public dos2unix
   (package
     (name "dos2unix")
-    (version "7.4.3")
+    (version "7.4.4")
     (source
      (origin
        (method url-fetch)
        (uri (string-append "https://waterlan.home.xs4all.nl/dos2unix/"
                            "dos2unix-" version ".tar.gz"))
        (sha256
-        (base32 "0wnacvz99rnlx0ayf5jrxwljvh801r8k1ai3hj137yfsaqcv93dn"))))
+        (base32 "0vj3wix17vl7a85hg673qqyrhw9sbq0xiadbbij7v0nm1gdl3a18"))))
     (build-system gnu-build-system)
     (arguments
-     `(#:make-flags
-       (list (string-append "CC=" ,(cc-for-target))
-             (string-append "prefix=" (assoc-ref %outputs "out")))
-       #:phases
-       (modify-phases %standard-phases
-         (delete 'configure)))) ; no configure script
+     (list #:make-flags
+           #~(list (string-append "CC=" #$(cc-for-target))
+                   (string-append "prefix=" #$output))
+           #:phases
+           #~(modify-phases %standard-phases
+               (delete 'configure)))) ; no configure script
     (native-inputs
-     `(("gettext" ,gettext-minimal)
-       ("perl" ,perl)))
+     (list gettext-minimal perl))
     (home-page "https://waterlan.home.xs4all.nl/dos2unix.html")
     (synopsis "DOS/Mac to Unix and vice versa text file format converter")
     (description
@@ -712,7 +711,8 @@ in a portable way.")
                            "dbacl-" version ".tar.gz"))
        (sha256
         (base32 "1gas0112wqjvwn9qg3hxnawk7h3prr0w9b2h68f3p1ifd1kzn3gz"))
-       (patches (search-patches "dbacl-include-locale.h.patch"))))
+       (patches (search-patches "dbacl-include-locale.h.patch"
+                                "dbacl-icheck-multiple-definitions.patch"))))
     (build-system gnu-build-system)
     (arguments
      `(#:make-flags
@@ -852,7 +852,7 @@ categories.")
                             (invoke "sh" "test_all.sh")))))))))
     (native-inputs (list which)) ;for tests
     (inputs (list pcre))
-    (home-page "http://drmtools.sourceforge.net/")
+    (home-page "https://drmtools.sourceforge.net/")
     (synopsis "Utilities to manipulate text and binary files")
     (description "The drm_tools package contains the following commands:
 @table @command
@@ -1082,7 +1082,7 @@ names like Euro.
 @item Handling (bullet, decimal, letter, roman) lists along with (attempt at)
 indentation.
 @end itemize\n")
-    (home-page "http://docx2txt.sourceforge.net")
+    (home-page "https://docx2txt.sourceforge.net")
     (license license:gpl3+)))
 
 (define-public html2text