summary refs log tree commit diff
path: root/gnu/packages/tls.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/tls.scm')
-rw-r--r--gnu/packages/tls.scm8
1 files changed, 6 insertions, 2 deletions
diff --git a/gnu/packages/tls.scm b/gnu/packages/tls.scm
index 9e2b4419bd..7858f06e9a 100644
--- a/gnu/packages/tls.scm
+++ b/gnu/packages/tls.scm
@@ -358,7 +358,10 @@ OpenSSL for TARGET."
         ((string-prefix? "powerpc64" target)
          "linux-ppc64")
         ((string-prefix? "powerpc" target)
-         "linux-ppc")))
+         "linux-ppc")
+        ((string-prefix? "riscv64" target)
+         ;; linux64-riscv64 isn't recognized until 3.0.0.
+         "linux-generic64")))
 
 (define-public openssl
   (package
@@ -404,7 +407,8 @@ OpenSSL for TARGET."
                 #~())
          ;; This test seems to be dependant on kernel features.
          ;; https://github.com/openssl/openssl/issues/12242
-         #$@(if (target-arm?)
+         #$@(if (or (target-arm?)
+                    (target-riscv64?))
               #~((replace 'check
                    (lambda* (#:key tests? test-target #:allow-other-keys)
                      (when tests?