summary refs log tree commit diff
path: root/gnu/packages/upnp.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/upnp.scm')
-rw-r--r--gnu/packages/upnp.scm4
1 files changed, 2 insertions, 2 deletions
diff --git a/gnu/packages/upnp.scm b/gnu/packages/upnp.scm
index 9b586c1cf2..358514f9d0 100644
--- a/gnu/packages/upnp.scm
+++ b/gnu/packages/upnp.scm
@@ -61,11 +61,11 @@
      ;; The build system does not use a configure script but depends on
      ;; `make'.  Hence we should pass parameters to `make' instead and remove
      ;; the configure phase.
-     '(#:make-flags
+     `(#:make-flags
        (list
         (string-append "SH=" (assoc-ref %build-inputs "bash") "/bin/sh")
         (string-append "INSTALLPREFIX=" (assoc-ref %outputs "out"))
-        "CC=gcc"
+        ,(string-append "CC=" (cc-for-target))
 
         ;; Allow executables to find libminiupnpc.so.
         (string-append "LDFLAGS=-Wl,-rpath="