summary refs log tree commit diff
path: root/gnu/packages/version-control.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/version-control.scm')
-rw-r--r--gnu/packages/version-control.scm56
1 files changed, 27 insertions, 29 deletions
diff --git a/gnu/packages/version-control.scm b/gnu/packages/version-control.scm
index 603e8a46dd..9ad4f3faca 100644
--- a/gnu/packages/version-control.scm
+++ b/gnu/packages/version-control.scm
@@ -1,7 +1,7 @@
 ;;; GNU Guix --- Functional package management for GNU
 ;;; Copyright © 2013 Nikita Karetnikov <nikita@karetnikov.org>
 ;;; Copyright © 2013 Cyril Roelandt <tipecaml@gmail.com>
-;;; Copyright © 2013, 2014, 2015, 2016, 2017 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2013, 2014, 2015, 2016, 2017, 2018 Ludovic Courtès <ludo@gnu.org>
 ;;; Copyright © 2013, 2014 Andreas Enge <andreas@enge.fr>
 ;;; Copyright © 2015, 2016 Mathieu Lirzin <mthl@gnu.org>
 ;;; Copyright © 2014, 2015, 2016 Mark H Weaver <mhw@netris.org>
@@ -347,7 +347,9 @@ as well as the classic centralized workflow.")
               (wrap-program git-sm
                 `("PATH" ":" prefix
                   (,(string-append (assoc-ref inputs "perl")
-                                   "/bin")))))))
+                                   "/bin"))))
+
+              #t)))
         (add-after 'split 'install-man-pages
           (lambda* (#:key inputs outputs #:allow-other-keys)
             (let* ((out (assoc-ref outputs "out"))
@@ -355,7 +357,7 @@ as well as the classic centralized workflow.")
                    (manpages (assoc-ref inputs "git-manpages")))
               (mkdir-p man)
               (with-directory-excursion man
-                (zero? (system* "tar" "xvf" manpages)))))))))
+                (invoke "tar" "xvf" manpages))))))))
 
    (native-search-paths
     ;; For HTTPS access, Git needs a single-file certificate bundle, specified
@@ -392,7 +394,9 @@ everything from small to very large projects with speed and efficiency.")
               (patches (search-patches "libgit2-0.25.1-mtime-0.patch"))
 
               ;; Remove bundled software.
-              (snippet '(delete-file-recursively "deps"))
+              (snippet '(begin
+                          (delete-file-recursively "deps")
+                          #t))
               (modules '((guix build utils)))))
     (build-system cmake-build-system)
     (outputs '("out" "debug"))
@@ -1138,23 +1142,21 @@ following features:
            (lambda* (#:key outputs #:allow-other-keys)
              ;; Follow the instructions from 'subversion/bindings/swig/INSTALL'.
              (let ((out (assoc-ref outputs "out")))
-               (and (zero? (system* "make" "swig-pl-lib"))
-                    ;; FIXME: Test failures.
-                    ;; (zero? (system* "make" "check-swig-pl"))
-                    (zero? (system* "make" "install-swig-pl-lib"))
-
-                    ;; Set the right installation prefix.
-                    (with-directory-excursion
-                        "subversion/bindings/swig/perl/native"
-                      (and (zero?
-                            (system* "perl" "Makefile.PL"
-                                     "NO_PERLLOCAL=1"
-                                     (string-append "PREFIX=" out)))
-                           (zero?
-                            (system* "make" "install"
-                                     (string-append "OTHERLDFLAGS="
-                                                    "-Wl,-rpath="
-                                                    out "/lib"))))))))))))
+               (invoke "make" "swig-pl-lib")
+               ;; FIXME: Test failures.
+               ;; (invoke "make" "check-swig-pl")
+               (invoke "make" "install-swig-pl-lib")
+
+               ;; Set the right installation prefix.
+               (with-directory-excursion
+                   "subversion/bindings/swig/perl/native"
+                 (invoke "perl" "Makefile.PL"
+                         "NO_PERLLOCAL=1"
+                         (string-append "PREFIX=" out))
+                 (invoke "make" "install"
+                         (string-append "OTHERLDFLAGS="
+                                        "-Wl,-rpath="
+                                        out "/lib")))))))))
     (native-inputs
       `(("pkg-config" ,pkg-config)
         ;; For the Perl bindings.
@@ -1578,11 +1580,6 @@ output of the 'git' command.")
                (base32
                 "1ydis4y0amkgfr4y60sn076f1l41ya2kn89kfd9fqf44f9ccgb5r"))))
     (build-system gnu-build-system)
-    (arguments
-     '(#:phases (modify-phases %standard-phases
-                  (add-after 'unpack 'bootstrap
-                    (lambda _
-                      (zero? (system* "autoreconf" "-vfi")))))))
     (native-inputs `(("autoconf" ,autoconf)
                      ("automake" ,automake)))
     (home-page "https://github.com/0-wiz-0/findnewest/releases")
@@ -1655,7 +1652,7 @@ repository\" with git-annex.")
 (define-public fossil
   (package
     (name "fossil")
-    (version "2.4")
+    (version "2.5")
     (source
      (origin
        (method url-fetch)
@@ -1669,7 +1666,7 @@ repository\" with git-annex.")
               "fossil-src-" version ".tar.gz")))
        (sha256
         (base32
-         "0add35lk2ac4qg29d7ygj7pskv8lfln33f3kgf6x3548msv9hd6j"))))
+         "1lxawkhr1ki9fqw8076fxib2b1w673449yzb6vxjshqzh5h77c7r"))))
     (build-system gnu-build-system)
     (native-inputs
      `(("tcl" ,tcl)                     ;for configuration only
@@ -1761,7 +1758,8 @@ be served with a HTTP file server of your choice.")
              (("__TIME__") "\"00:00:00\""))
            (substitute* "src/impossible.h"
              (("__DATE__") "\"\"")
-             (("__TIME__") "\"\""))))))
+             (("__TIME__") "\"\""))
+           #t))))
     (build-system haskell-build-system)
     (arguments
      `(#:configure-flags '("-fpkgconfig" "-fcurl" "-flibiconv" "-fthreaded"