summary refs log tree commit diff
path: root/gnu/packages/version-control.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/version-control.scm')
-rw-r--r--gnu/packages/version-control.scm11
1 files changed, 0 insertions, 11 deletions
diff --git a/gnu/packages/version-control.scm b/gnu/packages/version-control.scm
index 7f352d0b0b..aee424fbc9 100644
--- a/gnu/packages/version-control.scm
+++ b/gnu/packages/version-control.scm
@@ -617,17 +617,6 @@ also walk each side of a merge and test those changes individually.")
                         (substitute* (find-files "." ".*")
                           ((" perl -")
                            (string-append " " perl " -"))))))
-                  (add-before 'install 'fix-hooks-shebangs
-                    (lambda* (#:key inputs #:allow-other-keys)
-                      (let ((perl (string-append (assoc-ref inputs "perl")
-                                                 "/bin/perl")))
-                        ;; The files in 'lib/Gitolite/Hooks' keep references to
-                        ;; '/usr/bin/perl', without this fix it is impossible to
-                        ;; to run gitolite in production.
-                        (substitute* (find-files "src/lib/Gitolite/Hooks" ".*")
-                          (("/usr/bin/perl")
-                           perl))
-                        #t)))
                   (replace 'install
                     (lambda* (#:key outputs #:allow-other-keys)
                       (let* ((output (assoc-ref outputs "out"))