summary refs log tree commit diff
path: root/gnu/packages/version-control.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/version-control.scm')
-rw-r--r--gnu/packages/version-control.scm16
1 files changed, 9 insertions, 7 deletions
diff --git a/gnu/packages/version-control.scm b/gnu/packages/version-control.scm
index 04a6ae2a57..30660e830f 100644
--- a/gnu/packages/version-control.scm
+++ b/gnu/packages/version-control.scm
@@ -248,11 +248,9 @@ projects, from individuals to large-scale enterprise operations.")
     (home-page "http://www.gnu.org/software/rcs/")
     (synopsis "Per-file local revision control system")
     (description
-     "The GNU Revision Control System (RCS) manages multiple revisions of
-files. RCS automates the storing, retrieval, logging, identification, and
-merging of revisions.  RCS is useful for text that is revised frequently,
-including source code, programs, documentation, graphics, papers, and form
-letters.")
+     "RCS is the Revision Control System.  It is used to manage multiple
+revisions of files.  Revisions are stored as reverse differences generated by
+GNU Diffutils.  RCS also handles identifying and merging revisions.")
     (license gpl3+)))
 
 (define-public cvs
@@ -300,6 +298,10 @@ RCS, PRCS, and Aegis packages.")
     (home-page "http://www.gnu.org/software/vc-dwim/")
     (synopsis "Version-control-agnostic ChangeLog diff and commit tool")
     (description
-     "vc-dwim is a version-control-agnostic ChangeLog diff and commit
-tool. vc-chlog is a helper tool for writing GNU-style ChangeLog entries.")
+     "The vc-dwim package contains two tools, \"vc-dwim\" and \"vc-chlog\".
+vc-dwim is a tool that simplifies the task of maintaining a ChangeLog and
+using version control at the same time, for example by printing a reminder
+when a file change has been described in the ChangeLog but the file has not
+been added to the VCS.  vc-chlog scans changed files and generates
+standards-compliant ChangeLog entries based on the changes that it detects.")
     (license gpl3+)))